Sunbeam Rapier Owners Club
Sunbeam Rapier Owners Club
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Sunbeam Rapier Owners Club
 Introduce yourself
 Moving forward.....slowly

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List

* Forum Code is ON
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File


T O P I C    R E V I E W
oldcarnut Posted - 16 Jul 2016 : 18:45:47

See restoration section

5   L A T E S T    R E P L I E S    (Newest First)
oldcarnut Posted - 26 Sep 2016 : 19:46:49
Will update any progress on the car with a new post in the 'restorations' forum, thanks for your interest.
oldcarnut Posted - 14 Sep 2016 : 21:00:42
Will be back on with the Rapier next week. Had a bit of time on the other projects. Got a load of parts gathered up for the Rapier now so ready for another go at the old girl. Got the wheels back. Look great.Pics and story as we progress.
oldcarnut Posted - 14 Aug 2016 : 18:10:29
Got the engine sorted. Turned out to be the advance weights in the dissy were not moving. Been stood for 10 years or more. Engine trying to rev with no advance. Runs sweet now. Interior nearly done, will post pics when sorted.
oldcarnut Posted - 17 Jul 2016 : 21:59:29
Had a thought along those lines myself? On with a Wolseley Hornet as well, this has an electronic gizmatriod instead of contacts and car runs perfect. Might swap that over as is same Lucas dissy and see what happens. Cheers for your input, looking forward to getting it sorted.
bigt80 Posted - 16 Jul 2016 : 19:34:55
Hey, well done there OCN Series II eh, Rare! Nice to see another saved, it is looking good.
Just a thought on your running issues. I've had a similar problem in the past with a Fastback; started and idled but would not rev, after thinking it was fuel issue, it turned out to be a... condenser!
That was after putting a new 'Intermotor' one on, which made no difference as it was DOA!. But a good old Lucas one sorted it and it ran fine: may be worth a shot for a few quid.
Cheers for the photos. G.

Sunbeam Rapier Owners Club © 2009 Sunbeam Rapier Owners Club Go To Top Of Page
Snitz Forums 2000